When attempting to book a shipment using Whistl's Royal Mail services to a British Forces Post Office (BFPO) address, you might encounter the following error message:
address.postcode is not in the correct format
Cause
This error typically occurs because the service is not supported for BFPO postcodes. These postcodes differ from standard UK postcode formats.
Solution
To successfully send shipments to BFPO addresses via Royal Mail & Whistl, you will need a specific service enabled on your Whistl account.
- You will need to contact your Whistl account manager directly.
- Request that they enable an ALLSORT BFPO service for handling BFPO addresses on your account.
Once the correct service is enabled by Whistl, you will be able to book in BFPO postcode orders using this service.
If you have discussed this with Whistl and still encounter issues booking BFPO shipments, or have other questions, please feel free to contact our support team. You can call us on 0117 403 4313 (UK) / +1 (629) 666-6726 (US) or reach us online here.