In order to connect Shiptheory with your WooCommerce store, your installation and server must meet the following requirements:

  • WooCommerce version 3.0 or later.
  • WordPress version 4.4 or later.

           How to check your WooCommerce and WordPress versions

  • Your store must be fully HTTPS with a valid SSL certificate (not self-signed)
  • Your server must support POST/DELETE/PUT requests
    Check with your server host if you're not sure about either of these

  • REST API enabled in WooCommerce > Settings > API
    How to enable the REST API

  • Pretty permalinks in Settings > Permalinks
    How to enable Pretty permalinks


  • Cron must be running/enabled

  • If your Wordpress cron looks like above, please enable it.